aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Karl DeBisschop <kdebisschop@users.sourceforge.net> 2002-11-14 18:25:10 +0000
committerGravatar Karl DeBisschop <kdebisschop@users.sourceforge.net> 2002-11-14 18:25:10 +0000
commitc77ffcedc423655621be9803b7f710c758a959b7 (patch)
treebf61006f5399497f83fdd9de9fddad5048512c28 /configure.in
parentbe0cbafb0be470dcd3d29c20d7c5ce503c467bd4 (diff)
downloadmonitoring-plugins-c77ffcedc423655621be9803b7f710c758a959b7.tar.gz
fix bug with gettimeofday test, improve version/release handling, update rpm spec
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@200 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 15 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index c6730189..509b6236 100644
--- a/configure.in
+++ b/configure.in
@@ -3,11 +3,15 @@ include(`aclocal.m4')
include(`getloadavg.m4')
AC_REVISION ($Revision$)
AC_INIT(Helper.pm)
-PACKAGE_VERSION="1.3.0"
+VER=1.3.0
+REL=beta2
+AC_SUBST(VER)
+AC_SUBST(REL)
+PACKAGE_VERSION="${VER}-${REL}"
AC_SUBST(PACKAGE_VERSION)
PACKAGE_RELEASE="alpha1"
AC_SUBST(PACKAGE_RELEASE)
-AM_INIT_AUTOMAKE(nagios-plugins,${PACKAGE_VERSION}-${PACKAGE_RELEASE})
+AM_INIT_AUTOMAKE(nagios-plugins,${PACKAGE_VERSION})
AM_CONFIG_HEADER(plugins/config.h plugins/common.h plugins/version.h plugins/netutils.h plugins/utils.h plugins/popen.h)
AC_PREFIX_DEFAULT(/usr/local/nagios)
@@ -366,12 +370,15 @@ AC_TRY_COMPILE([#include <getopt.h>
DEPLIBS="$DEPLIBS libgetopt.a"])
AC_TRY_COMPILE([#include <sys/time.h>],
- [struct timeval *foo;],
- [AC_DEFINE(HAVE_STRUCT_TIMEVAL,1,[Define if we have a timeval structure])])
-
-AC_TRY_COMPILE([#include <sys/time.h>],
- [gettimeofday(NULL, NULL);],
- AC_DEFINE(HAVE_GETTIMEOFDAY,1,[Define if gettimeofday is found]))
+ [struct timeval *tv;
+ struct timezone *tz;],
+ AC_DEFINE(HAVE_STRUCT_TIMEVAL,1,[Define if we have a timeval structure])
+ AC_TRY_COMPILE([#include <sys/time.h>],
+ [struct timeval *tv;
+ struct timezone *tz;
+ gettimeofday(tv, tz);],
+ AC_DEFINE(HAVE_GETTIMEOFDAY,1,[Define if gettimeofday is found]),
+ AC_DEFINE(NEED_GETTIMEOFDAY,1,[Define if gettimeofday is needed])))
dnl Checks for library functions.
AC_CHECK_FUNCS(memmove select socket strdup strstr strtod strtol strtoul)