aboutsummaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2003-02-10 23:27:31 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2003-02-10 23:27:31 +0000
commit07a08052081b59d26add4adf0ae4519fbacb8a36 (patch)
treee1e81bfa5e0ffb304c02548aeb5d760b4d41c840 /plugins/Makefile.am
parentfb6811f9be0d85f5fceedb3ba7458e56386fc3a0 (diff)
downloadmonitoring-plugins-07a08052081b59d26add4adf0ae4519fbacb8a36.tar.gz
Remove unnecessary getopt references and link in lib directory
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@310 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am18
1 files changed, 4 insertions, 14 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index d21a20d0..664ac522 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,8 +1,8 @@
## Process this file with automake to produce Makefile.in
-VPATH = $(top_srcdir) $(top_srcdir)/plugins $(top_srcdir)/plugins/t
+VPATH = $(top_srcdir) $(top_srcdir)/lib $(top_srcdir)/plugins $(top_srcdir)/plugins/t
-INCLUDES = @LDAPINCLUDE@ @PGINCLUDE@ @SSLINCLUDE@
+INCLUDES = -I.. -I$(top_srcdir)/lib @LDAPINCLUDE@ @PGINCLUDE@ @SSLINCLUDE@
libexec_PROGRAMS = check_disk check_dummy check_http check_load \
check_mrtg check_mrtgtraf check_nwstat check_overcr check_ping \
@@ -16,12 +16,12 @@ EXTRA_PROGRAMS = check_mysql check_radius check_pgsql check_snmp check_hpjd \
check_tcp_programs = check_ftp check_imap check_nntp check_pop
-EXTRA_DIST = t utils.c netutils.c popen.c getopt.h getopt.c getopt1.c \
+EXTRA_DIST = t utils.c netutils.c popen.c \
snprintf.c getloadavg.c
PLUGINHDRS = common.h config.h
-BASEOBJS = utils.o
+BASEOBJS = utils.o ../lib/libnagiosplug.a
NETOBJS = netutils.o $(BASEOBJS)
NETLIBS = $(NETOBJS) $(SOCKETLIBS)
@@ -118,19 +118,9 @@ utils.o: utils.c utils.h $(PLUGINHDRS)
netutils.o: netutils.c netutils.h $(PLUGINHDRS)
-getopt.o: getopt.c getopt.h
- $(COMPILE) -c $(srcdir)/getopt.c -o $@
-
-getopt1.o: getopt1.c getopt.h
- $(COMPILE) -c $(srcdir)/getopt1.c -o $@
-
snprintf.o: snprintf.c
$(COMPILE) @NEED_VA_LIST@ -c $(srcdir)/snprintf.c -o $@
-libgetopt.a: getopt.o getopt1.o
- $(AR) -r $@ getopt.o getopt1.o
- $(RANLIB) $@
-
libsnprintf.a: snprintf.o
$(AR) -r $@ snprintf.o