aboutsummaryrefslogtreecommitdiff
path: root/plugins/tests/Makefile.am
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2006-01-30 16:10:50 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2006-01-30 16:10:50 +0000
commit795100ae5124915bb647a304d5dfe2ada2f44ab0 (patch)
treeb3fd0dc1a88ebb533f074c476ee020e32877632e /plugins/tests/Makefile.am
parentc8a9bf228fdd34b021796f577a404cb8b0cba1f9 (diff)
downloadmonitoring-plugins-795100ae5124915bb647a304d5dfe2ada2f44ab0.tar.gz
Added libtap tests for utils.c library functions. Removed redundant
test files git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1303 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'plugins/tests/Makefile.am')
-rw-r--r--plugins/tests/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/tests/Makefile.am b/plugins/tests/Makefile.am
new file mode 100644
index 00000000..0d82be12
--- /dev/null
+++ b/plugins/tests/Makefile.am
@@ -0,0 +1,21 @@
+
+noinst_PROGRAMS = @EXTRA_TEST@
+
+# These two lines support "make check", but we use "make test"
+TESTS = @EXTRA_TEST@
+check_PROGRAMS = @EXTRA_TEST@
+
+INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/intl
+
+EXTRA_PROGRAMS = test_utils
+
+LIBS = @LIBINTL@
+
+test_utils_SOURCES = test_utils.c
+test_utils_CFLAGS = -g -I..
+test_utils_LDFLAGS = -L..
+test_utils_LDADD = ../utils.o @EXTRA_TAPOBJ@
+
+test: ${noinst_PROGRAMS}
+ perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)
+