aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 43fe4ade..7efcb0f9 100644
--- a/configure.in
+++ b/configure.in
@@ -1632,6 +1632,12 @@ if test -n "$ac_cv_proc_meminfo"; then
EXTRAS="$EXTRAS check_swap"
fi
+AC_MSG_CHECKING([for /proc/pid/exe])
+if [readlink /proc/$$/exe > /dev/null 2>&1]; then
+ AC_MSG_RESULT([found])
+ AC_DEFINE(HAVE_PROC_PID_EXE,1,[Define if we have /proc/pid/exe])
+fi
+
AC_PATH_PROG(PATH_TO_DIG,dig)
AC_ARG_WITH(dig_command,
ACX_HELP_STRING([--with-dig-command=PATH],