aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fcd5c56b..8f7f4f9a 100644
--- a/configure.in
+++ b/configure.in
@@ -21,9 +21,38 @@ AC_PROG_INSTALL
AC_SUBST(INSTALL)
AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_GCC_TRADITIONAL
+AC_PROG_RANLIB
+AC_AIX
+AC_MINIX
+
AC_PROG_MAKE_SET
AC_PROG_AWK
+# Check for SunOS statfs brokenness wrt partitions 2GB and larger.
+# If <sys/vfs.h> exists and struct statfs has a member named f_spare,
+# enable the work-around code in fsusage.c.
+AC_MSG_CHECKING([for statfs that truncates block counts])
+AC_CACHE_VAL(fu_cv_sys_truncating_statfs,
+[AC_TRY_COMPILE([
+#if !defined(sun) && !defined(__sun)
+choke -- this is a workaround for a Sun-specific problem
+#endif
+#include <sys/types.h>
+#include <sys/vfs.h>],
+[struct statfs t; long c = *(t.f_spare);],
+fu_cv_sys_truncating_statfs=yes,
+fu_cv_sys_truncating_statfs=no,
+)])
+if test $fu_cv_sys_truncating_statfs = yes; then
+ AC_DEFINE(STATFS_TRUNCATES_BLOCK_COUNTS, 1,
+[ Define if the block counts reported by statfs may be truncated to 2GB
+ and the correct values may be stored in the f_spare array.
+ (SunOS 4.1.2, 4.1.3, and 4.1.3_U1 are reported to have this problem.
+ SunOS 4.1.1 seems not to be affected.)])
+fi
+
saved_srcdir=$srcdir
srcdir=$srcdir/lib
test -f $srcdir/getloadavg.c \
@@ -447,6 +476,15 @@ AC_HEADER_TIME
AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS(signal.h strings.h string.h syslog.h unistd.h uio.h errno.h regex.h sys/types.h sys/time.h sys/socket.h sys/loadavg.h)
AC_CHECK_HEADERS(stdarg.h sys/unistd.h unistd.h ctype.h stdlib.h)
+AC_CHECK_HEADERS(sys/vfs.h,
+ [AC_TRY_COMPILE([#include <sys/vfs.h>],
+ [struct statfs *buf],
+ [AC_DEFINE(HAVE_STRUCT_STATFS,1,[Define if statfs struct can be found])])])
+AC_CHECK_HEADERS(sys/param.h sys/mount.h,
+ [AC_TRY_COMPILE([#include <sys/param.h>
+#include <sys/mount.h>],
+ [struct statfs *buf],
+ [AC_DEFINE(HAVE_STRUCT_STATFS,1,[Define if statfs struct can be found])])])
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST