diff options
author | Jonas Gunz <himself@jonasgunz.de> | 2023-07-17 00:16:48 +0200 |
---|---|---|
committer | Jonas Gunz <himself@jonasgunz.de> | 2023-07-17 00:16:48 +0200 |
commit | df9f3bd75b32406fa7c34376af5ef97e230361bc (patch) | |
tree | c55848ab9bab9784f530d9102ee1ed0ed45868f1 | |
parent | 635ec022a87cb0789c6322275b41c3dfc51d36a4 (diff) | |
download | aurbuilder-df9f3bd75b32406fa7c34376af5ef97e230361bc.tar.gz |
readme, file structure
-rw-r--r-- | Readme.md | 46 | ||||
-rw-r--r-- | pkgbuild/PKGBUILD (renamed from PKGBUILD) | 4 | ||||
-rw-r--r-- | pkgbuild/aurbuilder.install (renamed from aurbuilder.install) | 0 |
3 files changed, 18 insertions, 32 deletions
@@ -1,12 +1,27 @@ # AUR PKG Builder -Docker base AUR Package builder for local arch repo +Automated AUR package buildsystem. +## Installation + +aurbuilder is designed to be run on Arch Linux. +Use the `PKGBUILD` in `pkgbuild/` to install with `makepkg -si`. + +Enable the systemd timers to activate the automated builds: +`systemctl enable aurbuilder-container.timer` and +`systemctl enable aurbuilder-package.timer`. + +## Usage + +Add packages to build in `/etc/aurbuilder/packages` (one per line). + +Builds can be manually triggered by `systemctl start aurbuilder-package.service`. +This requires a `aurbuilder-container.service` run to have completed beforehand. ## Locations -| localtion | description | +| location | description | | --- | --- | | `/srv/pkg` | Package output directory | | `/etc/aurbuilder` | Configuration files | @@ -14,30 +29,3 @@ Docker base AUR Package builder for local arch repo | `/usr/share/aurbuilder` | Container buildfiles | | `/usr/lib/aurbuilder` | Executables | | `/usr/lib/systemd/system` | Systemd Unitfiles | - -* Output, db and webroot `/srv/pkg/` -* Dockerfile and scripts for the Container `` -* Scripts `` - -## nginx - -Config in `nginx.conf` - -```nginx -# in http block - -include /etc/nginx/arch.conf; -#include /etc/nginx/arch_ssl.conf; -``` - -## Workflow - -Provided: Package name - -* search AUR for package (exact match only!) -* build dependency tree (also search with provided, then there is no exact match) -* prioritize packages in official repos. Don't build them. -* Add all AUR-PKGs in tree to to-build-list -* MAKEPKG ur way thourhg - - diff --git a/PKGBUILD b/pkgbuild/PKGBUILD index e5f4d71..93d4710 100644 --- a/PKGBUILD +++ b/pkgbuild/PKGBUILD @@ -11,7 +11,7 @@ depends=( podman bash ) makedepends=() optdepends=() source=(git+$url.git) -sha256sums=( SKIP ) #autofill using updpkgsums +sha256sums=( SKIP ) install=$pkgname.install pkgver() { @@ -29,6 +29,4 @@ package() { install -Dt $pkgdir/usr/lib/aurbuilder scripts/* install -Dt $pkgdir/usr/lib/systemd/system unitfiles/* install -Dt $pkgdir/etc/aurbuilder configs/* - } - diff --git a/aurbuilder.install b/pkgbuild/aurbuilder.install index c8f383c..c8f383c 100644 --- a/aurbuilder.install +++ b/pkgbuild/aurbuilder.install |