aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..2607263
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,26 @@
+from setuptools import setup, find_packages
+
+setup(
+ name='automato',
+ author="Jonas Gunz",
+ author_mail="himself@jonasgunz.de",
+ description="automato",
+ version='0.0.0',
+ packages=find_packages(),
+ entry_points = {
+ 'console_scripts': ['automato=automato.command_line:main'],
+ },
+ # TODO Check them
+ install_requires=[
+ "paramiko",
+ "pyparsing",
+ "PyYAML",
+ ],
+ long_description=open('README.md').read(),
+ long_description_content_type="text/markdown",
+ classifiers=[
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ ],
+)