aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar ghciv6 <ghciv6@maginus.de> 2020-04-13 20:44:26 +0200
committerGravatar Sven Nierlein <sven@nierlein.org> 2020-04-14 12:37:00 +0200
commit4264e7a6edb651793ef751723537767656a89e44 (patch)
tree080a76653745399136986d756a8729a71cfa3b8d /configure.ac
parentd008be68255b192f0354c523938c40643e39795f (diff)
downloadmonitoring-plugins-4264e7a6edb651793ef751723537767656a89e44.tar.gz
- workaround for issue #1550
- better use "ping -4" instead of "ping" if supported
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 08a0e782..4a9a92a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1064,6 +1064,14 @@ then
ac_cv_ping_packets_first=yes
AC_MSG_RESULT([$with_ping_command])
+elif $PATH_TO_PING -4 -n -U -w 10 -c 1 127.0.0.1 2>/dev/null | \
+ egrep -i "^round-trip|^rtt" >/dev/null
+then
+ # check if -4 is supported - issue #1550
+ with_ping_command="$PATH_TO_PING -4 -n -U -w %d -c %d %s"
+ ac_cv_ping_packets_first=yes
+ ac_cv_ping_has_timeout=yes
+ AC_MSG_RESULT([$with_ping_command])
elif $PATH_TO_PING -n -U -w 10 -c 1 127.0.0.1 2>/dev/null | \
egrep -i "^round-trip|^rtt" >/dev/null
then