aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Sven Nierlein <sven@nierlein.de> 2018-10-24 09:17:16 +0200
committerGravatar Sven Nierlein <sven@nierlein.de> 2018-10-24 09:17:16 +0200
commit7a46c98f830526a0e682d28d5a9db3d838ac9f36 (patch)
tree877c4111d911df374028cfb829a532a75cd55e4e /configure.ac
parent7501ba9f8a34413147281bed0b32b89da1ce2cb7 (diff)
downloadmonitoring-plugins-7a46c98f830526a0e682d28d5a9db3d838ac9f36.tar.gz
check_curl: do not build check_curl if curllibs are missing
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1fccf53d..725bf0ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -403,7 +403,6 @@ LIBCURL_CHECK_CONFIG(yes, 7.15.2, [
dnl Check for uriparser library
URIPARSER_CHECK(yes, 0.7.5, [
- _can_enable_check_curl=yes
URIPARSERINCLUDE="$URIPARSER_CPPFLAGS"
URIPARSERLIBS="$URIPARSER"
URIPARSERCFLAGS="$URIPARSER_CPPFLAGS"
@@ -418,10 +417,10 @@ URIPARSER_CHECK(yes, 0.7.5, [
dnl prerequisites met, enable the plugin
if test x$_can_enable_check_curl = xyes; then
-EXTRAS="$EXTRAS check_curl\$(EXEEXT)"
+ EXTRAS="$EXTRAS check_curl\$(EXEEXT)"
-dnl Enable bundled picohttpparser library (for now)
-AC_SUBST(PICOHTTPPARSER_DIR, picohttpparser)
+ dnl Enable bundled picohttpparser library (for now)
+ AC_SUBST(PICOHTTPPARSER_DIR, picohttpparser)
fi
AM_CONDITIONAL([WITH_CHECK_CURL], [test "$_can_enable_check_curl" = "yes"])
AM_COND_IF([WITH_CHECK_CURL],