aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2014-12-02 21:13:38 +0100
committerGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2014-12-02 21:13:38 +0100
commit8235fd0aef2945e0d638fba3493134588d085d5a (patch)
treeaafe5c7cf840fe013ca423445cc88bb5f8b1bc74 /configure.ac
parent04e0a182aeb5defaf6b39cbbd8d9c87491c4f1e4 (diff)
downloadmonitoring-plugins-8235fd0aef2945e0d638fba3493134588d085d5a.tar.gz
check_mailq: Add sudo support
This addition is based on a patch contributed by Christopher Schultz. Closes #1099. Closes #1171.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb8f9500..ce1728e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1484,6 +1484,16 @@ else
AC_MSG_WARN([Get ssh in order to make check_by_ssh plugin])
fi
+AC_PATH_PROG(PATH_TO_SUDO,sudo)
+AC_ARG_WITH(sudo_command,
+ ACX_HELP_STRING([--with-sudo-command=PATH],
+ [sets path to sudo]), PATH_TO_SUDO=$withval)
+if test -n "$PATH_TO_SUDO"
+then
+ AC_DEFINE_UNQUOTED(PATH_TO_SUDO,"$PATH_TO_SUDO",[path to sudo])
+else
+ AC_MSG_WARN([Could not find sudo or eqivalent])
+fi
AC_PATH_PROG(PATH_TO_MAILQ,mailq)
AC_ARG_WITH(mailq_command,