aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2014-06-22 14:10:38 +0200
committerGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2014-06-22 14:10:38 +0200
commitc0311d98481b783f1d24dd6c59fe25ce994a090d (patch)
treedafb02e27d2000fabcca60ac096a5f5368973c83 /configure.ac
parent22e7b78685747ded288642f25fefee7c57d3645a (diff)
downloadmonitoring-plugins-c0311d98481b783f1d24dd6c59fe25ce994a090d.tar.gz
check_radius: Support FreeRADIUS Client library
Allow for using the FreeRADIUS Client library instead of radiusclient or radiusclient-ng. The latter two projects are dead. Closes #1231.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a7501ab7..9aaa515e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -286,8 +286,15 @@ AS_IF([test "x$with_radius" != "xno"], [
RADIUSLIBS="-lradiusclient-ng"
AC_SUBST(RADIUSLIBS)
else
- AC_MSG_WARN([Skipping radius plugin])
- AC_MSG_WARN([install radius libs to compile this plugin (see REQUIREMENTS).])
+ AC_CHECK_LIB(freeradius-client,rc_read_config)
+ if test "$ac_cv_lib_freeradius_client_rc_read_config" = "yes"; then
+ EXTRAS="$EXTRAS check_radius\$(EXEEXT)"
+ RADIUSLIBS="-lfreeradius-client"
+ AC_SUBST(RADIUSLIBS)
+ else
+ AC_MSG_WARN([Skipping radius plugin])
+ AC_MSG_WARN([install radius libs to compile this plugin (see REQUIREMENTS).])
+ fi
fi
fi
LIBS="$_SAVEDLIBS"