aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Marc Sánchez <sanchezfauste@gmail.com> 2017-09-07 22:25:09 +0200
committerGravatar Marc Sánchez <sanchezfauste@gmail.com> 2017-09-07 22:25:09 +0200
commitc03e1ad081bc080cb8085bc14a94e4965a8e119e (patch)
tree23770f58a0b8b55604367a923ab081e259246472 /configure.ac
parent015a40e1b590bb847328d51bdfc4b544ae8825d3 (diff)
downloadmonitoring-plugins-c03e1ad081bc080cb8085bc14a94e4965a8e119e.tar.gz
Only turn on ordering procs by CPU usage if PS_USES_PROCPCPU
Disable sorting of procs by CPU usage on check_load if procpcpu is not present on PS_VARLIST
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bf129956..08a0e782 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1016,6 +1016,10 @@ if test -n "$ac_cv_ps_varlist" ; then
AC_DEFINE(PS_USES_PROCETIME,"yes",
[Whether the ps utility uses the "procetime" field])
fi
+ if echo "$ac_cv_ps_varlist" | grep "procpcpu" >/dev/null; then
+ AC_DEFINE(PS_USES_PROCPCPU,"yes",
+ [Whether the ps utility uses the "procpcpu" field])
+ fi
fi
AC_PATH_PROG(PATH_TO_PING,ping)