aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2013-08-18 00:30:58 +0200
committerGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2013-08-18 00:30:58 +0200
commit108baecaecbf09cc85c4925f82141beae40f7c1e (patch)
tree868b54bdb69676138153bc6ec7ffc24c3d4a6a03 /configure.in
parente4ccd85c5061fd2cc72e3f8ab7c9371751c93e34 (diff)
downloadmonitoring-plugins-108baecaecbf09cc85c4925f82141beae40f7c1e.tar.gz
check_fping: Use fping6(8) only if available
Let check_fping use IPv6 only if - the operating system supports IPv6, - the user didn't specify --without-ipv6, and - the "configure" script found the fping6(8) binary.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 9 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index a5d48421..43fe4ade 100644
--- a/configure.in
+++ b/configure.in
@@ -1378,28 +1378,26 @@ then
fi
AC_PATH_PROG(PATH_TO_FPING,fping)
+AC_PATH_PROG(PATH_TO_FPING6,fping6)
+
AC_ARG_WITH(fping_command,
ACX_HELP_STRING([--with-fping-command=PATH],
[Path to fping command]), PATH_TO_FPING=$withval)
+AC_ARG_WITH(fping6_command,
+ ACX_HELP_STRING([--with-fping6-command=PATH],
+ [Path to fping6 command]), PATH_TO_FPING6=$withval)
+
if test -n "$PATH_TO_FPING"
then
AC_DEFINE_UNQUOTED(PATH_TO_FPING,"$PATH_TO_FPING",[path to fping])
EXTRAS="$EXTRAS check_fping"
+ if test x"$with_ipv6" != xno && test -n "$PATH_TO_FPING6"; then
+ AC_DEFINE_UNQUOTED(PATH_TO_FPING6,"$PATH_TO_FPING6",[path to fping6])
+ fi
else
AC_MSG_WARN([Get fping from http://www.fping.com in order to make check_fping plugin])
fi
-AC_PATH_PROG(PATH_TO_FPING6,fping6)
-AC_ARG_WITH(fping6_command,
- ACX_HELP_STRING([--with-fping6-command=PATH],
- [Path to fping6 command]), PATH_TO_FPING6=$withval)
-if test -n "$PATH_TO_FPING6"
-then
- AC_DEFINE_UNQUOTED(PATH_TO_FPING6,"$PATH_TO_FPING6",[path to fping6])
-else
- AC_MSG_WARN([Get fping6 from http://www.fping.com in order to make check_fping plugin])
-fi
-
AC_PATH_PROG(PATH_TO_SSH,ssh)
AC_ARG_WITH(ssh_command,
ACX_HELP_STRING([--with-ssh-command=PATH],