aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2007-01-25 00:26:20 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2007-01-25 00:26:20 +0000
commit2e6a2e433fdfda7534918bf20280c0e04f997a00 (patch)
treee137d614b1fdb413d4c277aacf651a7896bf83cf /configure.in
parent49d8064bf3986f3c57385e643aa865dd1390271e (diff)
downloadmonitoring-plugins-2e6a2e433fdfda7534918bf20280c0e04f997a00.tar.gz
Use build-aux directory. Removed unnecessary checks in configure.in.
Keeping libtool to link to libtap - can't find a suitable replacement method git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1582 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 4 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 52156fa4..a4a2de33 100644
--- a/configure.in
+++ b/configure.in
@@ -4,9 +4,9 @@ AC_PREREQ(2.59)
AC_INIT(nagios-plugins,1.4.5)
AC_CONFIG_SRCDIR(NPTest.pm)
AC_CONFIG_FILES(gl/Makefile)
+AC_CONFIG_AUX_DIR(build-aux)
AM_INIT_AUTOMAKE([1.8.3])
AM_CONFIG_HEADER(config.h)
-dnl Not yet - AC_CONFIG_AUX_DIR(build-aux)
AC_CANONICAL_HOST
RELEASE=1
@@ -26,15 +26,9 @@ AC_SUBST(INSTALL)
AC_PROG_CC
gl_EARLY
-AC_PROG_CPP
AC_PROG_GCC_TRADITIONAL
AC_PROG_LIBTOOL
-AC_PROG_MAKE_SET
-AC_PROG_AWK
-
-AC_FUNC_MALLOC
-AC_FUNC_REALLOC
AC_FUNC_ERROR_AT_LINE
ifdef([AC_FUNC_STRTOD],[AC_FUNC_STRTOD],[AM_FUNC_STRTOD])
@@ -401,11 +395,10 @@ dnl
dnl Checks for header files.
dnl
-AC_HEADER_STDC
AC_HEADER_TIME
AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS(signal.h strings.h string.h syslog.h uio.h errno.h sys/types.h sys/time.h sys/socket.h sys/un.h sys/poll.h)
-AC_CHECK_HEADERS(features.h stdarg.h sys/unistd.h ctype.h stdlib.h)
+AC_CHECK_HEADERS(signal.h syslog.h uio.h errno.h sys/time.h sys/socket.h sys/un.h sys/poll.h)
+AC_CHECK_HEADERS(features.h stdarg.h sys/unistd.h ctype.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -444,7 +437,7 @@ AC_TRY_COMPILE([#include <sys/time.h>],
AC_DEFINE(NEED_GETTIMEOFDAY,1,[Define if gettimeofday is needed])))
dnl Checks for library functions.
-AC_CHECK_FUNCS(memmove select socket strdup strstr strtod strtol strtoul floor)
+AC_CHECK_FUNCS(memmove select socket strdup strstr strtol strtoul floor)
AC_CHECK_FUNCS(poll)
AC_MSG_CHECKING(return type of socket size)