aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2007-03-06 17:29:15 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2007-03-06 17:29:15 +0000
commit4ad5dcce03df2e0167c8aae6f9f5debfe173f5a4 (patch)
treee9d16d19a492d536bdfcdecb42fa322cd19d4643 /configure.in
parenta483e079daa8fae0ff61d5f236c8040b14087d2b (diff)
downloadmonitoring-plugins-4ad5dcce03df2e0167c8aae6f9f5debfe173f5a4.tar.gz
Use /usr/ucb/ps on Solaris in preference to pst3 (problems in 64bit mode)
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1629 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 9 insertions, 23 deletions
diff --git a/configure.in b/configure.in
index b0d1c97d..3b8db841 100644
--- a/configure.in
+++ b/configure.in
@@ -493,30 +493,16 @@ if test -n "$PS_COMMAND" && test -n "$PS_FORMAT" && test -n "$PS_COLS" && test -
ac_cv_ps_cols="$PS_COLS"
AC_MSG_RESULT([(command-line) $ac_cv_ps_command])
-dnl Now using the pst3/kmem hack for solaris systems to avoid truncation
-elif test "$ac_cv_uname_s" = "SunOS"; then
- #
- # this is a very, very ugly hack, to hardcode the location for plugins
- #
- if test "$libexecdir" = '${exec_prefix}/libexec'; then
- if test "$exec_prefix" = "NONE"; then
- if test "$prefix" = "NONE"; then
- pst3="$ac_default_prefix/libexec/pst3"
- else
- pst3="$prefix/libexec/pst3"
- fi
- else
- pst3="$exec_prefix/libexec/pst3"
- fi
- else
- pst3="$libexecdir/pst3"
- fi
- ac_cv_ps_command="$pst3"
- ac_cv_ps_format="%s %d %d %d %d %f %s %n"
- ac_cv_ps_varlist="[procstat,&procuid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]"
+dnl Using /usr/ucb/ps on Solaris systems, to avoid truncation
+dnl Limitation that command name is not available
+elif test "$ac_cv_uname_s" = "SunOS" && /usr/ucb/ps -alxwwn 2>/dev/null | \
+ egrep -i ["^ *F +UID +PID +PPID +%C +PRI +NI +SZ +RSS +WCHAN +S +TT +TIME +COMMAND"] > /dev/null
+then
+ ac_cv_ps_varlist="[&procuid,&procpid,&procppid,&procpcpu,&procvsz,&procrss,procstat,&pos]"
+ ac_cv_ps_command="/usr/ucb/ps -alxwwn"
+ ac_cv_ps_format=["%*s %d %d %d %d %*d %*d %d %d%*[ 0123456789abcdef]%[OSRZT]%*s %*s %n"]
ac_cv_ps_cols=8
- AC_MSG_RESULT([using nagios-plugins internal ps for solaris])
- EXTRAS_ROOT="$EXTRAS_ROOT pst3"
+ AC_MSG_RESULT([$ac_cv_ps_command])
dnl Some gnu/linux systems (debian for one) don't like -axwo and need axwo.
dnl so test for this first...