aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Thomas Guyot-Sionnest <dermoth@aei.ca> 2008-11-26 05:42:48 -0500
committerGravatar Thomas Guyot-Sionnest <dermoth@aei.ca> 2008-11-26 05:42:48 -0500
commit9bcfa9cdede27be34d11f42dfae3d8fd60fc92bc (patch)
tree77f11fd6fb26c9ac4d8a410983629927c70d5319 /configure.in
parented9a088b37dcb8ba56d397592f4e8230a6a011e5 (diff)
downloadmonitoring-plugins-9bcfa9cdede27be34d11f42dfae3d8fd60fc92bc.tar.gz
Disable dynamic versionning for releases, and allow generating version out of subversion.
This should be a definitive fix for systems with non-compilant make programs as the version will be taken from $(PACKAGE_VERSION) instead. At the same time I added code for generating svn-based version strings.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 203166e4..8cae5341 100644
--- a/configure.in
+++ b/configure.in
@@ -98,6 +98,9 @@ AC_SUBST(PKG_ARCH)
AC_SUBST(REV_DATESTAMP)
AC_SUBST(REV_TIMESTAMP)
+dnl Check if version file is present
+AM_CONDITIONAL([RELEASE_PRESENT], [test -f release])
+
dnl Checks for programs.
AC_PATH_PROG(PYTHON,python)
AC_PATH_PROG(SH,sh)