aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2005-09-12 10:31:29 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2005-09-12 10:31:29 +0000
commite85edd9e55d79b7e475f009df64accb65f317905 (patch)
tree1adf431a06733721b459d673fc1214295f53774a /configure.in
parent3c554b72de0df28175e7ed8a0bcf3b7e509335d9 (diff)
downloadmonitoring-plugins-e85edd9e55d79b7e475f009df64accb65f317905.tar.gz
ECHILD error at waitpid on Red Hat systems (Peter Pramberger and
Sascha Runschke - 1250191) git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1213 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5453fe1d..4f9dc1c9 100644
--- a/configure.in
+++ b/configure.in
@@ -1520,6 +1520,22 @@ AC_SUBST(DEPLIBS)
AM_GNU_GETTEXT([no-libtool], [need-ngettext])
AM_GNU_GETTEXT_VERSION(0.11.5)
+dnl Check for Redhat spopen problem
+dnl Wierd problem where ECHILD is returned from a wait call in error
+dnl Only appears to affect nslookup and dig calls. Only affects redhat around
+dnl 2.6.9-11 (okay in 2.6.9-5). Redhat investigating root cause
+dnl We patch plugins/popen.c
+if echo $ac_cv_uname_r | egrep "\.EL$" >/dev/null 2>&1 ; then
+ AC_MSG_CHECKING(for redhat spopen problem)
+ ( cd config_test && make && make test ) > /dev/null 2>&1
+ if test $? -eq 0 ; then
+ AC_MSG_RESULT(okay)
+ else
+ AC_MSG_RESULT(error)
+ AC_DEFINE(REDHAT_SPOPEN_ERROR, 1, "Problem on redhat with spopen")
+ fi
+fi
+
dnl External libraries - see ACKNOWLEDGEMENTS
np_COREUTILS
np_CURL