aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorGravatar Jeremy T. Bouse <undrgrid@users.sourceforge.net> 2003-03-15 01:25:35 +0000
committerGravatar Jeremy T. Bouse <undrgrid@users.sourceforge.net> 2003-03-15 01:25:35 +0000
commit11b35b92e3195d230bef359f6a0679ae4414716b (patch)
treef4911e5804c1f3037dcf63bbbf0b823c5ac19e5f /lib/Makefile.am
parent6cf5fc3c74c0bdfef6c4cc1b627578378ad3a407 (diff)
downloadmonitoring-plugins-11b35b92e3195d230bef359f6a0679ae4414716b.tar.gz
Spent the day working on backwards compatability using getaddrinfo()
Moved getaddrinfo.? and gethostbyname.? from lib/ to plugins/ due to problems with compiling into the libnagiosplug.a as it required linking against socket libraries which are unneeded except for network based plugins. This code should hopefully happily work for all systems and has been tested prior to commit on Debian GNU/Linux, SPARC Solaris 7 and SPARC Solaris 9. git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@424 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index b24bc407..9a26e419 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -2,12 +2,8 @@
noinst_LIBRARIES = libnagiosplug.a
-noinst_HEADERS = getopt.h getaddrinfo.h gethostbyname.h
+noinst_HEADERS = getopt.h
libnagiosplug_a_SOURCES = getopt.c getopt1.c getloadavg.c snprintf.c
-libnagiosplug_a_DEPENDENCIES = @LIBOBJS@
-
INCLUDES = -I$(srcdir)
-
-EXTRA_DIST = getaddrinfo.c gethostbyname.c