aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2004-12-15 20:47:26 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2004-12-15 20:47:26 +0000
commit82d1989d3245791c9fac22ca848f5497f261c10b (patch)
tree240017a6fcdcf7ecb5cfb2cbefb57de24de8b7c7 /lib/Makefile.am
parent953a933e4d5900ec3c497781dab26066fef1e78b (diff)
downloadmonitoring-plugins-82d1989d3245791c9fac22ca848f5497f261c10b.tar.gz
Moving m4 files into m4/. Added extra coreutils files required from
autoconf tests. Updated Makefile.am to have nagiosplug lib and a separate coreutils lib git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1027 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am44
1 files changed, 31 insertions, 13 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 3250cdb3..80f3e62e 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,20 +1,38 @@
## Process this file with automake to produce Makefile.in
-noinst_LIBRARIES = libnagiosplug.a
+noinst_LIBRARIES = libcoreutils.a libnagiosplug.a
-libnagiosplug_a_SOURCES = getopt.c getopt1.c fsusage.c snprintf.c mountlist.c \
- xmalloc.c xstrdup.c exitfail.c
+# Will auto pick up fsusage.c mountlist.c
+libcoreutils_a_SOURCES = \
+ cloexec.c cloexec.h \
+ exit.h \
+ exitfail.c exitfail.h \
+ fsusage.h \
+ full-read.c full-read.h \
+ full-write.c full-write.h \
+ getopt.c getopt.h getopt1.c \
+ gettext.h \
+ mountlist.h \
+ safe-read.c safe-read.h \
+ safe-write.c safe-write.h \
+ unlocked-io.h \
+ xalloc.h \
+ xmalloc.c \
+ xstrdup.c
-libnagiosplug_a_LIBADD = @LIBOBJS@
-libnagiosplug_a_DEPENDENCIES = $(libnagiosplug_a_LIBADD)
+other_coreutils_files = \
+ error.c error.h \
+ fsusage.c \
+ getloadaavg.c \
+ malloc.c \
+ mountlist.c \
+ realloc.c \
+ strtod.c
-# Extra GNU libraries required if target is missing these functions
-EXTRA_DIST = ulonglong.m4 codeset.m4 gettext.m4 glibc21.m4 iconv.m4 intdiv0.m4 \
- inttypes.m4 inttypes_h.m4 inttypes-pri.m4 isc-posix.m4 lcmessage.m4 lib-ld.m4 \
- lib-link.m4 lib-prefix.m4 progtest.m4 stdint_h.m4 uintmax_t.m4 afs.m4 \
- fstypename.m4 fsusage.m4 ls-mntd-fs.m4 getopt.h gettext.h fsusage.h mountlist.h\
- error.m4 error.h error.c getloadavg.c xalloc.h unlocked-io.h unlocked-io.m4 malloc.c \
- onceonly.m4 realloc.c strtod.c exitfail.h full-read.h xstrdup.c xalloc.m4 exit.h \
- cloexec.c cloexec.h getopt.m4 exitfail.m4
+libcoreutils_a_LIBADD = $(LIBOBJS)
+libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD)
+
+libnagiosplug_a_SOURCES = snprintf.c
INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl
+