aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2006-05-18 22:05:43 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2006-05-18 22:05:43 +0000
commita8cd7705e7898d77764aa12ddcc2e29de1860138 (patch)
tree970f609cbecbe515998907fd55a12f814ad2edcd /lib/Makefile.am
parent08394ddb2d62ec8aab9121e45ab9c1a102e85ba4 (diff)
downloadmonitoring-plugins-a8cd7705e7898d77764aa12ddcc2e29de1860138.tar.gz
Synchronise with coreutils 2.95. Gettext now synced with coreutils,
so no longer development platform requirement git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1394 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am38
1 files changed, 26 insertions, 12 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 0612a759..0d69089e 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -6,29 +6,28 @@ noinst_LIBRARIES = libcoreutils.a libnagiosplug.a
libcoreutils_a_SOURCES = \
cloexec.c cloexec.h \
exit.h \
- exitfail.c exitfail.h \
- fsusage.h \
full-read.c full-read.h \
full-write.c full-write.h \
- getopt.c getopt.h getopt1.c \
gettext.h \
- mountlist.h \
safe-read.c safe-read.h \
- safe-write.c safe-write.h \
- unlocked-io.h \
- xalloc.h \
- xmalloc.c \
- xstrdup.c
+ safe-write.c safe-write.h xalloc-die.c
other_coreutils_files = \
error.c error.h \
fsusage.c \
- getloadaavg.c \
+ getloadavg.c \
malloc.c \
mountlist.c \
realloc.c \
- stdbool_.h \
- strtod.c
+ strtod.c \
+ exitfail.c exitfail.h \
+ fsusage.h \
+ getopt.c getopt1.c \
+ mountlist.h \
+ unlocked-io.h \
+ xalloc.h \
+ xmalloc.c
+
libcoreutils_a_LIBADD = $(LIBOBJS)
libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD)
@@ -37,6 +36,10 @@ libnagiosplug_a_SOURCES = snprintf.c
INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl
+print_coreutil_files:
+ @echo $(libcoreutils_a_SOURCES) $(other_coreutils_files) $(EXTRA_DIST)
+
+# Below are from coreutil's lib/Makefile.am
BUILT_SOURCES = $(STDBOOL_H)
EXTRA_DIST = stdbool_.h
MOSTLYCLEANFILES = stdbool.h stdbool.ht
@@ -45,3 +48,14 @@ stdbool.h: stdbool_.h
sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool_.h > $@t
mv $@t $@
+BUILT_SOURCES += $(GETOPT_H)
+EXTRA_DIST += getopt_.h getopt_int.h
+
+# We need the following in order to create an <getopt.h> when the system
+# doesn't have one that works with the given compiler.
+all-local $(lib_OBJECTS): $(GETOPT_H)
+getopt.h: getopt_.h
+ cp $(srcdir)/getopt_.h $@-t
+ mv $@-t $@
+MOSTLYCLEANFILES += getopt.h getopt.h-t
+