aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2007-01-24 22:47:25 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2007-01-24 22:47:25 +0000
commitfe856aa957978504137c1d425815d4ed8a22be40 (patch)
treea5bb46ce0e64b2056f75700eadbf27aba7c39418 /lib/Makefile.am
parent210f39bc84cfbb21cd72dc054e43f13815ee0616 (diff)
downloadmonitoring-plugins-fe856aa957978504137c1d425815d4ed8a22be40.tar.gz
Sync with gnulib - lots of extraneous code removed in preference to GNU code
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1580 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am79
1 files changed, 4 insertions, 75 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 7edac1f2..3909bb9b 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -2,85 +2,14 @@
SUBDIRS = tests
-noinst_LIBRARIES = libcoreutils.a libnagiosplug.a
+noinst_LIBRARIES = libnagiosplug.a
-# Will auto pick up fsusage.c mountlist.c
-libcoreutils_a_SOURCES = \
- cloexec.c cloexec.h \
- exit.h \
- full-read.c full-read.h \
- full-write.c full-write.h \
- gettext.h \
- safe-read.c safe-read.h \
- safe-write.c safe-write.h strcase.h xalloc-die.c
-# intprops.h required for getloadavg.c
-# This needs to be an EXTRA_DIST because the m4s
-# that have AC_LIBSOURCES for intprops.h are not necessary and
-# the getloadavg m4 is an autoconf one, so doesn't
-# know about intprops.h. Confused? You will be!
-EXTRA_DIST = intprops.h
+libnagiosplug_a_SOURCES = utils_base.c utils_disk.c
+EXTRA_DIST = utils_base.h utils_disk.h
-other_coreutils_files = \
- error.c error.h \
- fsusage.c \
- getloadavg.c \
- malloc.c \
- mountlist.c \
- realloc.c \
- strtod.c \
- exitfail.c exitfail.h \
- fsusage.h \
- getopt.c getopt1.c \
- mountlist.h \
- unlocked-io.h \
- xalloc.h \
- xmalloc.c
-
-
-libcoreutils_a_LIBADD = $(LIBOBJS) $(ALLOCA)
-libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD)
-lib_OBJECTS = $(libcoreutils_a_OBJECTS)
-
-libnagiosplug_a_SOURCES = snprintf.c utils_base.c utils_disk.c
-EXTRA_DIST += utils_base.h utils_disk.h
-
-INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
-
-print_coreutil_files:
- @echo $(libcoreutils_a_SOURCES) $(other_coreutils_files) $(EXTRA_DIST)
+INCLUDES = -I$(srcdir) -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
test:
cd tests && make test
-# Below are from coreutil's lib/Makefile.am
-BUILT_SOURCES = $(STDBOOL_H)
-EXTRA_DIST += stdbool_.h
-MOSTLYCLEANFILES = stdbool.h stdbool.ht
-# Create stdbool.h on systems that lack a working one.
-stdbool.h: stdbool_.h
- sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool_.h > $@t
- mv $@t $@
-
-BUILT_SOURCES += $(ALLOCA_H)
-EXTRA_DIST += alloca_.h
-
-# We need the following in order to create an <alloca.h> when the system
-# doesn't have one that works with the given compiler
-all-local $(lib_OBJECTS): $(ALLOCA_H)
-alloca.h: alloca_.h
- cp $(srcdir)/alloca_.h $@-t
- mv $@-t $@
-MOSTLYCLEANFILES += alloca.h alloca.h-t
-
-BUILT_SOURCES += $(GETOPT_H)
-EXTRA_DIST += getopt_.h getopt_int.h
-
-# We need the following in order to create an <getopt.h> when the system
-# doesn't have one that works with the given compiler.
-all-local $(lib_OBJECTS): $(GETOPT_H)
-getopt.h: getopt_.h
- cp $(srcdir)/getopt_.h $@-t
- mv $@-t $@
-MOSTLYCLEANFILES += getopt.h getopt.h-t
-