aboutsummaryrefslogtreecommitdiff
path: root/plugins-root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Thomas Guyot-Sionnest <dermoth@users.sourceforge.net> 2008-11-23 05:38:47 +0000
committerGravatar Thomas Guyot-Sionnest <dermoth@users.sourceforge.net> 2008-11-23 05:38:47 +0000
commit6fbd14fea5c111a23d9074d25499991cbfa58f79 (patch)
tree0c1f5a77cacc664eadd47216b70e3257337484db /plugins-root/Makefile.am
parent56cf151ae91c5081a99365848a3f060dfe14a68c (diff)
downloadmonitoring-plugins-6fbd14fea5c111a23d9074d25499991cbfa58f79.tar.gz
Removing CVS/SVN tags and replacing with git-based versioning
For contrib/, full tags have been imported from subversion git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@2091 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'plugins-root/Makefile.am')
-rw-r--r--plugins-root/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/plugins-root/Makefile.am b/plugins-root/Makefile.am
index 107d9933..de8813ff 100644
--- a/plugins-root/Makefile.am
+++ b/plugins-root/Makefile.am
@@ -1,5 +1,11 @@
## Process this file with automake to produce Makefile.in
+NP-VERSION-FILE: .FORCE-NP-VERSION-FILE
+ @$(SHELL_PATH) $(top_srcdir)/NP-VERSION-GEN
+-include NP-VERSION-FILE
+
+AM_CFLAGS = -DNP_VERSION='"$(NP_VERSION)"'
+
VPATH = $(top_srcdir) $(top_srcdir)/lib $(top_srcdir)/plugins $(top_srcdir)/plugins/t $(srcdir)
INCLUDES = -I.. -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins @SSLINCLUDE@
@@ -74,3 +80,10 @@ pst3_LDFLAGS = @PST3CFLAGS@
check_dhcp_DEPENDENCIES = check_dhcp.c $(NETOBJS) $(DEPLIBS)
check_icmp_DEPENDENCIES = check_icmp.c $(NETOBJS)
+
+all-local: .FORCE-NP-VERSION-FILE
+
+clean-local:
+ rm -f NP-VERSION-FILE
+
+.PHONY: .FORCE-NP-VERSION-FILE