aboutsummaryrefslogtreecommitdiff
path: root/plugins-root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2006-04-28 08:45:24 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2006-04-28 08:45:24 +0000
commite4c86b373db06ce6603fe39d1f2442e6e4b908b6 (patch)
tree3cb25b47b6ca541ec8550aef2b77534136ca8688 /plugins-root/Makefile.am
parent34cb16d283298885b73f75146433a703e93c0d4f (diff)
downloadmonitoring-plugins-e4c86b373db06ce6603fe39d1f2442e6e4b908b6.tar.gz
Added pst3 into distribution (Jason Kau - 1476451)
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1384 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'plugins-root/Makefile.am')
-rw-r--r--plugins-root/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/plugins-root/Makefile.am b/plugins-root/Makefile.am
index 54e91b08..782a1ca7 100644
--- a/plugins-root/Makefile.am
+++ b/plugins-root/Makefile.am
@@ -9,12 +9,11 @@ localedir = $(datadir)/locale
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
LIBS = @LIBINTL@ @LIBS@ @SSLLIBS@
-EXTRA_PROGRAMS = check_dhcp check_icmp
+libexec_PROGRAMS = check_dhcp check_icmp @EXTRAS_ROOT@
-if WANT_PST3
- EXTRA_PROGRAMS += pst3
- pst3_DEPENDENCIES = pst3.c
-endif
+EXTRA_PROGRAMS = pst3
+
+EXTRA_DIST = pst3.c
BASEOBJS = ../plugins/utils.o ../lib/libnagiosplug.a ../lib/libcoreutils.a
NETOBJS = ../plugins/netutils.o $(BASEOBJS) $(EXTRA_NETOBJS)
@@ -27,8 +26,6 @@ TESTS = @PLUGIN_TEST@
test:
perl -I $(top_builddir) -I $(top_srcdir) ../test.pl
-all-local: $(EXTRA_PROGRAMS)
-
setuid_root_mode = 4550
group = nagios