aboutsummaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorGravatar M. Remy <mremy@gmx.ch> 2012-04-17 22:15:15 +0200
committerGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2012-06-07 10:14:16 +0200
commit3e622f3a47bc7d31f22513a79892c3c52febd2d3 (patch)
tree75df841b5d21b36cd869a574e7857ec6a49fb6ae /plugins/Makefile.am
parent679a2296065893fd428891d610499c04a50aaa29 (diff)
downloadmonitoring-plugins-3e622f3a47bc7d31f22513a79892c3c52febd2d3.tar.gz
check_users: improve performance
This patch use the utxent function family to collect the user data. It improve the check speed. Need a system conforming to POSIX.1-2001.
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 36a28b0b..3a2afc15 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -101,7 +101,7 @@ check_tcp_LDADD = $(SSLOBJS) $(NETLIBS) $(SSLLIBS)
check_time_LDADD = $(NETLIBS)
check_ntp_time_LDADD = $(NETLIBS) $(MATHLIBS)
check_ups_LDADD = $(NETLIBS)
-check_users_LDADD = $(BASEOBJS) popen.o
+check_users_LDADD = $(BASEOBJS)
check_by_ssh_LDADD = $(NETLIBS)
check_ide_smart_LDADD = $(BASEOBJS)
negate_LDADD = $(BASEOBJS)