aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 59875e5a..6dacd4f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -544,6 +544,18 @@ else
with_gnutls="no"
fi
+dnl Check for POSIX thread libraries
+AC_CHECK_HEADERS(pthread.h)
+case $host in
+ *sun* | *solaris*)
+ AC_CHECK_LIB(pthread,pthread_create,THRLIBS="-lpthread -lrt")
+ ;;
+ *)
+ AC_CHECK_LIB(pthread,pthread_create,THRLIBS="-lpthread")
+ ;;
+esac
+AC_SUBST(THRLIBS)
+
dnl
dnl Checks for header files.
dnl