aboutsummaryrefslogtreecommitdiff
path: root/plugins-root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins-root/Makefile.am')
-rw-r--r--plugins-root/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/plugins-root/Makefile.am b/plugins-root/Makefile.am
index 2a2987d7..f5ecc461 100644
--- a/plugins-root/Makefile.am
+++ b/plugins-root/Makefile.am
@@ -33,7 +33,7 @@ group = nagios
# /* Author Coreutils team - see ACKNOWLEDGEMENTS */
INSTALL_SUID = \
- for f in $(EXTRA_PROGRAMS) ; do \
+ for f in $(libexec_PROGRAMS) ; do \
p=$$f; \
echo " $(INSTALL_PROGRAM) $$p $(DESTDIR)$(libexecdir)/$$p"; \
$(INSTALL_PROGRAM) $$p $(DESTDIR)$(libexecdir)/$$p; \
@@ -43,10 +43,10 @@ INSTALL_SUID = \
chmod $(setuid_root_mode) $(DESTDIR)$(libexecdir)/$$p; \
done
-install-root: $(EXTRA_PROGRAMS)
+install-root: $(libexec_PROGRAMS)
@$(INSTALL_SUID)
-install-exec-local: $(EXTRA_PROGRAMS)
+install-exec-local: $(libexec_PROGRAMS)
@TMPFILE=$(DESTDIR)$(libexecdir)/.setuid-$$$$; \
rm -f $$TMPFILE; \
echo > $$TMPFILE; \