summaryrefslogtreecommitdiff
path: root/misc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'misc/PKGBUILD')
-rw-r--r--misc/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/misc/PKGBUILD b/misc/PKGBUILD
new file mode 100644
index 0000000..b8bb86d
--- /dev/null
+++ b/misc/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Joe User <joe.user@example.com>
+
+pkgname=libtermgl
+pkgver=1.0
+pkgrel=1
+pkgdesc="Terminal Graphics Library"
+arch=('i686' 'x86_64')
+url="https://github.com/kompetenzbolzen/termgl"
+license=('MIT')
+groups=()
+depends=('glibc')
+makedepends=()
+optdepends=()
+source=("git+https://github.com/kompetenzbolzen/termgl")
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/termgl
+ make
+}
+
+package() {
+ cd $srcdir/termgl
+ make PREFIX="$pkgdir/" install
+}
+
+post_install() {
+ ldconfig -n -v /usr/lib
+}