aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2007-09-13 11:36:57 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2007-09-13 11:36:57 +0000
commit0708e6fa812387214ca1da00d8bad941a2ad5aff (patch)
tree6c544412e666c80a3600f8e33f6a466c714a3328 /Makefile.am
parent29d5acb7c821c8be23b32be9e01b242efad5b872 (diff)
downloadmonitoring-plugins-0708e6fa812387214ca1da00d8bad941a2ad5aff.tar.gz
Adding in optional Nagios::Plugin perl module (and
dependencies) compilation and installation git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1777 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b76bf76d..5c25f334 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = gl lib plugins plugins-scripts plugins-root po
+SUBDIRS = gl lib plugins plugins-scripts plugins-root po @PERLMODS_DIR@
EXTRA_DIST = config.rpath \
ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS BUGS CODING FAQ LEGAL NEWS \
@@ -23,8 +23,9 @@ install-root:
test:
cd lib && $(MAKE) test
- cd plugins; $(MAKE) test
- cd plugins-scripts; $(MAKE) test
+ if test "$(PERLMODS_DIR)" != ""; then cd perlmods && $(MAKE) test; fi
+ cd plugins && $(MAKE) test
+ cd plugins-scripts && $(MAKE) test
nagios-plugins.spec: nagios-plugins.spec.in
sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;s/^%%{requires}$$//" $? > $@