aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2008-06-26 22:00:08 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2008-06-26 22:00:08 +0000
commit6c476db6dcc7aa70a687d09c10e6ad515c290c23 (patch)
tree01262e224740a0b01fe018eb167b3c46de3a6ea7 /Makefile.am
parent2968a166e2524c5c1c557a12ae8dd6eaf698d7ea (diff)
downloadmonitoring-plugins-6c476db6dcc7aa70a687d09c10e6ad515c290c23.tar.gz
Adding libtap into distribution to help run C based tests
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@2013 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 416ef62b..98b0dcc4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,7 @@ EXTRA_DIST = config.rpath \
NPTest.pm contrib pkg nagios-plugins.spec \
config_test/Makefile config_test/run_tests config_test/child_test.c \
perlmods tools/build_perl_modules \
- tools/tinderbox_build
+ tools/tinderbox_build @TAP_DIR@
ACLOCAL_AMFLAGS = -I gl/m4 -I m4
@@ -22,7 +22,10 @@ dist-hook:
install-root:
cd plugins-root && $(MAKE) $@
-test test-debug:
+tap:
+ cd @TAP_DIR@ && $(MAKE)
+
+test test-debug: tap
cd lib && $(MAKE) $@
if test "$(PERLMODS_DIR)" != ""; then cd perlmods && $(MAKE) $@; fi
cd plugins && $(MAKE) $@