aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Jeremy T. Bouse <undrgrid@users.sourceforge.net> 2003-03-23 07:01:20 +0000
committerGravatar Jeremy T. Bouse <undrgrid@users.sourceforge.net> 2003-03-23 07:01:20 +0000
commit739ea144d276ca475730d0c928ed9fd82f3cba03 (patch)
tree58fad2d7ab1427e06150c53cdcb3e41a5d03f9f5 /Makefile.am
parentc9d73535b59fef3056c65c3be6e1e18e4509629a (diff)
downloadmonitoring-plugins-739ea144d276ca475730d0c928ed9fd82f3cba03.tar.gz
Solaris package build system
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@449 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 9 insertions, 23 deletions
diff --git a/Makefile.am b/Makefile.am
index 33182593..8cc15144 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@
SUBDIRS = lib plugins plugins-scripts
EXTRA_DIST = CODING FAQ LEGAL REQUIREMENTS SUPPORT \
- Helper.pm contrib nagios-plugins.spec.in
+ Helper.pm contrib pkg nagios-plugins.spec.in
ACLOCAL_AMFLAGS = -I lib
@@ -18,31 +18,17 @@ nagios-plugins.spec: nagios-plugins.spec.in
sed "s/%%{VER}/${VER}/;s/%%{REL}/${REL}/;" $? > $@
# Solaris pkgmk
-PACKDIR=build-pkg
+BUILDDIR=`pwd`/build-solaris
+PACKDIR=`pwd`/build-pkg
VERSION=@PACKAGE_VERSION@
-Prototype:
+solpkg:
+ if [ ! -d $(BUILDDIR) ] ; then mkdir $(BUILDDIR); fi
if [ ! -d $(PACKDIR) ] ; then mkdir $(PACKDIR); fi
- cd build-solaris
$(MAKE) all
- $(MAKE) DESTDIR=../$(PACKDIR) install
- cd ..
- echo i pkginfo> Prototype
- if [ -f checkinstall ] ; then echo i checkinstall>> Prototype; fi
- if [ -f preinstall ] ; then echo i preinstall>> Prototype; fi
- if [ -f postinstall ] ; then echo i postinstall>> Prototype; fi
- pkgproto $(PACKDIR)=/ | sed -e "s|$(LOGNAME) $(GROUP)$$|root root|" | egrep -v "(s|d) none (/|/etc|/var|/usr|/usr/local) " >> Prototype
-
-pkgmap: ../Prototype
- mkdir -p $(PACKDIR)/nagiosp
- cd $(PACKDIR)/nagiosp
- pkgmk -o -r / -f ../Prototype -d $(PACKDIR) nagiosp
- cd ..
-
-nagios.SPARC.pkg.tar.gz: pkgmap
- cd $(PACKDIR) && tar -cf - nagiosp | gzip -9 -c > ../nagiosp.SPARC.pkg.tar.gz
-
-pkgset: nagiosp.SPARC.pkg.tar.gz
+ $(MAKE) DESTDIR=$(BUILDDIR) install
+ $(INSTALL) pkg/solaris/pkginfo $(BUILDDIR)
+ $(cd $(BUILDDIR) && `pwd`/pkg/solaris/solpkg $(PACKDIR))
pkgclean:
- rm -rf Prototype nagiosp.SPARC.pkg.tar.gz
+ rm -rf $(BUILDDIR) $(PACKDIR)