aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Thomas Guyot-Sionnest <dermoth@aei.ca> 2008-11-26 05:42:48 -0500
committerGravatar Thomas Guyot-Sionnest <dermoth@aei.ca> 2008-11-26 05:42:48 -0500
commit9bcfa9cdede27be34d11f42dfae3d8fd60fc92bc (patch)
tree77f11fd6fb26c9ac4d8a410983629927c70d5319 /Makefile.am
parented9a088b37dcb8ba56d397592f4e8230a6a011e5 (diff)
downloadmonitoring-plugins-9bcfa9cdede27be34d11f42dfae3d8fd60fc92bc.tar.gz
Disable dynamic versionning for releases, and allow generating version out of subversion.
This should be a definitive fix for systems with non-compilant make programs as the version will be taken from $(PACKAGE_VERSION) instead. At the same time I added code for generating svn-based version strings.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3cd939ac..70325781 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,7 @@ DEFS = -DLOCALEDIR=\"$(localedir)\"
dist-hook:
make THANKS nagios-plugins.spec pkg/fedora/nagios-plugins.spec
- echo ${VERSION} >$(distdir)/version
+ echo ${VERSION} >$(distdir)/release
install-root:
cd plugins-root && $(MAKE) $@