aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Karl DeBisschop <kdebisschop@users.sourceforge.net> 2004-03-02 06:17:53 +0000
committerGravatar Karl DeBisschop <kdebisschop@users.sourceforge.net> 2004-03-02 06:17:53 +0000
commite2e3017e7af883503eb42d28ba69a90274a016d2 (patch)
treef6c9013688a66e50e0b83449bbfb67c445b17abd /Makefile.am
parent439bf19ea97fd72f058ea2124b39fd4b920fd8b2 (diff)
downloadmonitoring-plugins-e2e3017e7af883503eb42d28ba69a90274a016d2.tar.gz
make specfile into a template which can generate a generic spec plus specs suitable for various repositories
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@837 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f427a11a..21778407 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,14 +12,18 @@ localedir = $(datadir)/locale
DEFS = -DLOCALEDIR=\"$(localedir)\"
dist-hook:
- make THANKS nagios-plugins.spec
+ make THANKS nagios-plugins.spec pkg/fedora/nagios-plugins.spec
test:
cd plugins; $(MAKE) test
cd plugins-scripts; $(MAKE) test
nagios-plugins.spec: nagios-plugins.spec.in
- sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;" $? > $@
+ sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;s/^%%{requires}$$//" $? > $@
+
+pkg/fedora/nagios-plugins.spec: nagios-plugins.spec.in
+ $(top_srcdir)/mkinstalldirs pkg/fedora
+ sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;/^# Requires$$/r $(top_srcdir)/pkg/fedora/requires" $? > $@
# Solaris pkgmk
BUILDDIR = build-solaris