aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Karl DeBisschop <kdebisschop@users.sourceforge.net> 2003-09-04 06:43:38 +0000
committerGravatar Karl DeBisschop <kdebisschop@users.sourceforge.net> 2003-09-04 06:43:38 +0000
commitfee4763db44ef71dff247d97d28ec4f670acbed0 (patch)
tree3808fa3a1436b666bb87e52d40d34fb396270c1e /Makefile.am
parent699d1f4188ad430fcbea445fe39bfb536fd731e5 (diff)
downloadmonitoring-plugins-fee4763db44ef71dff247d97d28ec4f670acbed0.tar.gz
change so make-dist works in subdirs
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@715 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 50c7edde..7fe5447c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ SUBDIRS = intl lib plugins plugins-scripts po
EXTRA_DIST = config.rpath \
ABOUT-NLS CODING FAQ LEGAL REQUIREMENTS SUPPORT THANKS \
- Helper.pm contrib pkg nagios-plugins.spec.in
+ Helper.pm contrib pkg nagios-plugins.spec
ACLOCAL_AMFLAGS = -I lib
@@ -12,7 +12,7 @@ localedir = $(datadir)/locale
DEFS = -DLOCALEDIR=\"$(localedir)\"
dist-hook:
- sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;" $(srcdir)/nagios-plugins.spec.in > $(distdir)/nagios-plugins.spec
+ make THANKS nagios-plugins.spec
test:
cd plugins; $(MAKE) test
@@ -34,8 +34,12 @@ solpkg:
$(INSTALL) pkg/solaris/pkginfo $(BUILDDIR)
cd $(BUILDDIR) && $(PERL) ../$(PKGSCRIPT) ../$(PACKDIR)
-THANKS: THANKS.in AUTHORS
- perl -e ' while (<>) { print STDERR "Duplicate: $$_",$$/ if ($$a{$$_}) ; $$a{$$_}++}; print sort by_last_field (keys %a); sub by_last_field { ($$a1) = $$a =~ /\s(\w+)$$/; ($$b1) = $$b =~ /\s(\w+)$$/; $$a1 cmp $$b1}' AUTHORS | cat THANKS.in - > $@
+THANKS: AUTHORS
+ @echo "This software is brought to you by the Nagios Plugins Development Team. However," > $@
+ @echo "there have been many contributors to this project. Everyone below has helped in " >> $@
+ @echo "raising bug reports, creating patches or contributing new plugins." >> $@
+ @echo "" >> $@
+ perl -e ' while (<>) { print STDERR "Duplicate: $$_",$$/ if ($$a{$$_}) ; $$a{$$_}++}; print sort by_last_field (keys %a); sub by_last_field { ($$a1) = $$a =~ /\s(\w+)$$/; ($$b1) = $$b =~ /\s(\w+)$$/; $$a1 cmp $$b1}' $? >> $@
pkgclean:
rm -rf $(BUILDDIR) $(PACKDIR)