aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2016-11-18 11:51:12 +0100
committerGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2016-11-18 11:51:12 +0100
commit303acfc64f2f656729bde803a410a10a80a76b40 (patch)
tree9bcc6015490531921ad5794ac55382a3a0aa96ee /configure.ac
parent1723a3c7610cc43438c51d1e5fed43e15099a60e (diff)
parentfe1c4bb0e5ea3632d608a6b8b7e51d580856d833 (diff)
downloadmonitoring-plugins-303acfc64f2f656729bde803a410a10a80a76b40.tar.gz
Merge remote-tracking branch 'monitoring-plugins/pr/1443'
* monitoring-plugins/pr/1443: add openssl 1.1 support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1368780f..367e82a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -500,15 +500,15 @@ if ! test x"$with_openssl" = x"no"; then
dnl Check for crypto lib
_SAVEDLIBS="$LIBS"
LIBS="-L${with_openssl}/lib"
- AC_CHECK_LIB(crypto,CRYPTO_lock)
- if test "$ac_cv_lib_crypto_CRYPTO_lock" = "yes"; then
+ AC_CHECK_LIB(crypto,CRYPTO_new_ex_data)
+ if test "$ac_cv_lib_crypto_CRYPTO_new_ex_data" = "yes"; then
dnl Check for SSL lib
AC_CHECK_LIB(ssl,main, SSLLIBS="-lssl -lcrypto",,-lcrypto)
fi
LIBS="$_SAVEDLIBS"
dnl test headers and libs to decide whether check_http should use SSL
- if test "$ac_cv_lib_crypto_CRYPTO_lock" = "yes"; then
+ if test "$ac_cv_lib_crypto_CRYPTO_new_ex_data" = "yes"; then
if test "$ac_cv_lib_ssl_main" = "yes"; then
if test "$FOUNDINCLUDE" = "yes"; then
FOUNDOPENSSL="yes"