aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2014-02-28 13:28:33 +0100
committerGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2014-02-28 13:28:33 +0100
commitc08d6a429ba0e0cd3642ba2c2fe85687472ee22f (patch)
tree396a37ae462543f0e28f36501c30796b3eb91249 /configure.ac
parente260efb25690b13002a0bf432507f66bdad90f02 (diff)
downloadmonitoring-plugins-c08d6a429ba0e0cd3642ba2c2fe85687472ee22f.tar.gz
Replace "plugins-scripts/subst.in" foo
Remove the buggy and complex awk(1) magic in "plugins-scripts/subst.in" in favor of simple sed(1) substitutions. The plugins in the "plugins-scripts" directory now always use the PATH specified via "./configure --trusted-path", or the default PATH hard-coded in "configure.ac". Fixes #1242.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5759e60b..a1ef4451 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,7 @@ AM_MAINTAINER_MODE([enable])
AC_CONFIG_HEADERS([config.h])
AC_CANONICAL_HOST
+DEFAULT_PATH="/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin"
RELEASE=1
AC_SUBST(RELEASE)
@@ -75,7 +76,8 @@ AC_DEFINE_UNQUOTED(CGIURL,"$CGIURL",[URL of CGI programs])
AC_ARG_WITH(trusted_path,
ACX_HELP_STRING([--with-trusted-path=PATH],
[sets trusted path for executables called by scripts]),
- with_trusted_path=$withval)
+ with_trusted_path=$withval,
+ with_trusted_path=$DEFAULT_PATH)
AC_SUBST(with_trusted_path)
EXTRAS=
@@ -1781,7 +1783,6 @@ AC_OUTPUT(
lib/tests/Makefile
plugins-root/Makefile
plugins-scripts/Makefile
- plugins-scripts/subst
plugins-scripts/utils.pm
plugins-scripts/utils.sh
perlmods/Makefile