aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2007-09-13 11:36:57 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2007-09-13 11:36:57 +0000
commit0708e6fa812387214ca1da00d8bad941a2ad5aff (patch)
tree6c544412e666c80a3600f8e33f6a466c714a3328 /configure.in
parent29d5acb7c821c8be23b32be9e01b242efad5b872 (diff)
downloadmonitoring-plugins-0708e6fa812387214ca1da00d8bad941a2ad5aff.tar.gz
Adding in optional Nagios::Plugin perl module (and
dependencies) compilation and installation git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1777 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 86f37809..9067978a 100644
--- a/configure.in
+++ b/configure.in
@@ -1503,6 +1503,16 @@ elif test "$ac_cv_enable_redhat_pthread_workaround" = "yes" ; then
AC_DEFINE(REDHAT_SPOPEN_ERROR, 1, [Forced workaround on redhat in spopen])
fi
+dnl Perl modules
+AC_ARG_ENABLE(perl-modules,
+ AC_HELP_STRING([--enable-perl-modules],
+ [Enables installation of Nagios::Plugin and its dependencies (default: no)]),
+ [enable_perl_modules=$enableval],
+ [enable_perl_modules=no])
+if test "$enable_perl_modules" = "yes" ; then
+ AC_SUBST(PERLMODS_DIR,perlmods)
+fi
+
dnl External libraries - see ACKNOWLEDGEMENTS
gl_INIT
@@ -1521,6 +1531,7 @@ AC_OUTPUT(
plugins-scripts/subst
plugins-scripts/utils.pm
plugins-scripts/utils.sh
+ perlmods/Makefile
command.cfg
test.pl
pkg/solaris/pkginfo
@@ -1558,6 +1569,7 @@ ACX_FEATURE([with],[mysql])
ACX_FEATURE([with],[openssl])
ACX_FEATURE([with],[gnutls])
ACX_FEATURE([with],[perl])
+ACX_FEATURE([enable],[perl-modules])
ACX_FEATURE([with],[cgiurl])
ACX_FEATURE([with],[trusted-path])