aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Jeremy T. Bouse <undrgrid@users.sourceforge.net> 2003-03-15 01:25:35 +0000
committerGravatar Jeremy T. Bouse <undrgrid@users.sourceforge.net> 2003-03-15 01:25:35 +0000
commit11b35b92e3195d230bef359f6a0679ae4414716b (patch)
treef4911e5804c1f3037dcf63bbbf0b823c5ac19e5f /configure.in
parent6cf5fc3c74c0bdfef6c4cc1b627578378ad3a407 (diff)
downloadmonitoring-plugins-11b35b92e3195d230bef359f6a0679ae4414716b.tar.gz
Spent the day working on backwards compatability using getaddrinfo()
Moved getaddrinfo.? and gethostbyname.? from lib/ to plugins/ due to problems with compiling into the libnagiosplug.a as it required linking against socket libraries which are unneeded except for network based plugins. This code should hopefully happily work for all systems and has been tested prior to commit on Debian GNU/Linux, SPARC Solaris 7 and SPARC Solaris 9. git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@424 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ec3606e1..eea01da4 100644
--- a/configure.in
+++ b/configure.in
@@ -386,7 +386,7 @@ else
if test x$enable_emulate_getaddrinfo != xyes ; then
AC_MSG_ERROR([getaddrinfo not found: try --with-lwres or --enable-emulate-getaddrinfo])
fi
- LIBOBJS="$LIBOBJS getaddrinfo.o"
+ EXTRA_NETOBJS="$EXTRA_NETOBJS getaddrinfo.o"
fi
if test x"$enable_emulate_getaddrinfo" != xno ; then
@@ -414,7 +414,8 @@ if test x"$enable_emulate_getaddrinfo" != xno ; then
AC_SEARCH_LIBS(gethostbyname, resolv bind nsl, ,
[AC_MSG_ERROR([cannot find gethostbyname])])
fi
- LIBOBJS="$LIBOBJS gethostbyname.o"
+ EXTRA_NETOBJS="$EXTRA_NETOBJS gethostbyname.o"
+ AC_DEFINE(EMULATE_GETADDRINFO,1,[Define if emulating getaddrinfo])
fi
@@ -1451,7 +1452,7 @@ AC_TRY_COMPILE([#ifdef __STDC__
[NEED_VA_LIST=-DNEED_VA_LIST AC_SUBST(NEED_VA_LIST) AC_MSG_RESULT(no)])
AC_SUBST(EXTRAS)
-AC_SUBST(LIBOBJS)
+AC_SUBST(EXTRA_NETOBJS)
AC_SUBST(DEPLIBS)
AC_DEFINE_UNQUOTED(PACKAGE_VERSION,"${VERSION}",[package version])