aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Subhendu Ghosh <sghosh@users.sourceforge.net> 2003-04-13 04:28:58 +0000
committerGravatar Subhendu Ghosh <sghosh@users.sourceforge.net> 2003-04-13 04:28:58 +0000
commit1934d3c2252f4f2f9539acedf93737887598d34b (patch)
treeff135b982294eafb0ac31b889f930fad27a9a464 /configure.in
parent664be83730ff97368e8bfcf5e1fc4db2435d2c3a (diff)
downloadmonitoring-plugins-1934d3c2252f4f2f9539acedf93737887598d34b.tar.gz
update for check_mailq - qmail support
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@491 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 690e8941..a7f3d1f3 100644
--- a/configure.in
+++ b/configure.in
@@ -1257,6 +1257,14 @@ else
AC_MSG_WARN([Could not find mailq or eqivalent])
fi
+AC_PATH_PROG(PATH_TO_QMAIL_QSTAT,qmail-qstat)
+if test -x "$PATH_TO_QMAIL_QSTAT"
+then
+ AC_DEFINE_UNQUOTED(PATH_TO_MAILQ,"$PATH_TO_QMAIL_QSTAT",[path to qmail-qstat])
+else
+ AC_MSG_WARN([Could not find qmail-qstat or eqivalent])
+fi
+
dnl SWAP info required is amount allocated/available and amount free
dnl The plugin works through all the swap devices and adds up the total swap
dnl available.