aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar nagiosplugins <nagiosplugins@nagiosplugins.org> 2009-09-25 08:18:04 +0000
committerGravatar nagiosplugins <nagiosplugins@nagiosplugins.org> 2009-09-25 09:31:04 +0000
commit43c187a9444ddfdac26fb5c2e2f21dd38c72ce8d (patch)
treec510f5c620d3a8c17f29ab5635cbf78fcb893d41 /configure.in
parent53efa53d5de82631accb2ac98c876f9fa477d19d (diff)
downloadmonitoring-plugins-43c187a9444ddfdac26fb5c2e2f21dd38c72ce8d.tar.gz
Allow custom versions with the release file...
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 505af93e..5cc693c2 100644
--- a/configure.in
+++ b/configure.in
@@ -101,6 +101,14 @@ AC_SUBST(REV_TIMESTAMP)
dnl Check if version file is present
AM_CONDITIONAL([RELEASE_PRESENT], [test -f release])
+# Also read in the version from it
+if test -f release; then
+ NP_RELEASE="$(<release)"
+else
+ NP_RELEASE="$PACKAGE_VERSION"
+fi
+AC_SUBST(NP_RELEASE)
+
dnl Checks for programs.
AC_PATH_PROG(PYTHON,python)
AC_PATH_PROG(SH,sh)