aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2008-06-26 22:00:08 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2008-06-26 22:00:08 +0000
commit6c476db6dcc7aa70a687d09c10e6ad515c290c23 (patch)
tree01262e224740a0b01fe018eb167b3c46de3a6ea7 /configure.in
parent2968a166e2524c5c1c557a12ae8dd6eaf698d7ea (diff)
downloadmonitoring-plugins-6c476db6dcc7aa70a687d09c10e6ad515c290c23.tar.gz
Adding libtap into distribution to help run C based tests
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@2013 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 15 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 612d6869..afde8374 100644
--- a/configure.in
+++ b/configure.in
@@ -154,12 +154,6 @@ AC_CHECK_HEADERS(math.h)
AC_CHECK_LIB(m,floor,MATHLIBS="-lm")
AC_SUBST(MATHLIBS)
-dnl Check for libtap, to run perl-like tests
-AC_CHECK_LIB(tap, plan_tests,
- EXTRA_TEST="test_utils test_disk test_tcp test_cmd test_base64"
- AC_SUBST(EXTRA_TEST)
- )
-
dnl INI Parsing
AC_ARG_ENABLE(extra-opts,
AC_HELP_STRING([--enable-extra-opts],
@@ -1595,6 +1589,21 @@ if test "$ac_cv_uname_s" = 'SunOS' -a \( "x$ac_cv_prog_ac_ct_AR" = "x" -o "$ac_c
AC_MSG_ERROR(No ar found for Solaris - is /usr/ccs/bin in PATH?)
fi
+AC_ARG_ENABLE(libtap,
+ AC_HELP_STRING([--enable-libtap],
+ [Enables configuring of libtap in external/tap/. Run "make tap" to compile (default: no)]),
+ [enable_libtap=$enableval],
+ [enable_libtap=no])
+dnl Have to define TAP_DIR so that Makefile can pull it as an extra dist
+TAP_DIR=external/tap-1.01
+AC_SUBST(TAP_DIR)
+if test "$enable_libtap" = yes; then
+ dnl Have to have AC_CONFIG_SUBDIRS as a literal
+ AC_CONFIG_SUBDIRS([external/tap-1.01])
+ EXTRA_TEST="test_utils test_disk test_tcp test_cmd test_base64"
+ AC_SUBST(EXTRA_TEST)
+fi
+
AC_OUTPUT(
Makefile
lib/Makefile