aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Karl DeBisschop <kdebisschop@users.sourceforge.net> 2004-02-25 07:49:12 +0000
committerGravatar Karl DeBisschop <kdebisschop@users.sourceforge.net> 2004-02-25 07:49:12 +0000
commit8809baebc0d825b5ca966a4e7f412aa2ec627a2a (patch)
treec5571a2708a744e1e168d5355fc0b6d59b712d26 /configure.in
parentb8c407e0f5df94186363ac16c610bcef85745aa5 (diff)
downloadmonitoring-plugins-8809baebc0d825b5ca966a4e7f412aa2ec627a2a.tar.gz
pass timeout to ping if supported with -w parameter (linux)
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@824 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5dc04f94..3f909295 100644
--- a/configure.in
+++ b/configure.in
@@ -871,6 +871,7 @@ AC_ARG_WITH(ping_command,
AC_MSG_CHECKING(for ICMP ping syntax)
ac_cv_ping_packets_first=no
+ac_cv_ping_has_timeout=no
if test -n "$with_ping_command"
then
AC_MSG_RESULT([(command-line) $with_ping_command])
@@ -887,6 +888,14 @@ then
ac_cv_ping_packets_first=yes
AC_MSG_RESULT([$with_ping_command])
+elif $PATH_TO_PING -n -U -w 10 -c 1 127.0.0.1 2>/dev/null | \
+ egrep -i "^round-trip|^rtt" >/dev/null
+then
+ with_ping_command="$PATH_TO_PING -n -U -w %d -c %d %s"
+ ac_cv_ping_packets_first=yes
+ ac_cv_ping_has_timeout=yes
+ AC_MSG_RESULT([$with_ping_command])
+
elif $PATH_TO_PING -n -U -c 1 127.0.0.1 2>/dev/null | \
egrep -i "^round-trip|^rtt" >/dev/null
then
@@ -952,6 +961,12 @@ then
[Define if packet count must precede host])
fi
+if test "x$ac_cv_ping_has_timeout" != "xno"
+then
+ AC_DEFINE(PING_HAS_TIMEOUT,1,
+ [Define if ping has its own timeout option that should be set])
+fi
+
AC_ARG_WITH(ping6_command,
ACX_HELP_STRING([--with-ping6-command=SYNTAX],
[sets syntax for ICMPv6 ping]),