aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2004-11-29 22:42:01 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2004-11-29 22:42:01 +0000
commitb00c8a2c9f8ab62abb2ce14ba26853cda3df91eb (patch)
tree7b33b5f6b19defe592d0c097cfb320f18c109521 /configure.in
parent8017a63d26f07d47ea8356588d7b38af952a5da5 (diff)
downloadmonitoring-plugins-b00c8a2c9f8ab62abb2ce14ba26853cda3df91eb.tar.gz
Patches for configure on *BSD (Julien Touche)
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@950 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8d8e1e3e..ddf1f249 100644
--- a/configure.in
+++ b/configure.in
@@ -469,7 +469,13 @@ AC_HEADER_TIME
AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS(signal.h strings.h string.h syslog.h uio.h errno.h regex.h sys/types.h sys/time.h sys/socket.h sys/loadavg.h)
AC_CHECK_HEADERS(features.h stdarg.h sys/unistd.h ctype.h stdlib.h)
-AC_CHECK_HEADERS(limits.h sys/param.h sys/mount.h sys/vfs.h sys/fs/s5param.h sys/filsys.h fcntl.h sys/statfs.h sys/dustat.h sys/statvfs.h)
+AC_CHECK_HEADERS(limits.h sys/param.h)
+AC_CHECK_HEADERS([sys/mount.h],[],[],[
+#ifdef HAVE_SYS_PARAM_H
+#include <sys/param.h>
+#endif
+])
+AC_CHECK_HEADERS(sys/vfs.h sys/fs/s5param.h sys/filsys.h fcntl.h sys/statfs.h sys/dustat.h sys/statvfs.h)
# glibc 2.3.2 stdlib.h does not define HUGE_VAL (see man strtod)
AC_MSG_CHECKING([for HUGE_VAL in <stdlib.h>])
@@ -1378,21 +1384,29 @@ dnl fwict, the 2-arg is an SVR4 standard, whereas the 3-arg is shared
dnl in the various BSD's
dnl
-AC_CHECK_HEADERS([sys/swap.h sys/stat.h sys/param.h])
+AC_CHECK_HEADERS([sys/swap.h], [], [], [
+#ifdef HAVE_SYS_PARAM_H
+#include <sys/param.h>
+#endif
+])
+AC_CHECK_HEADERS([sys/stat.h sys/param.h])
AC_CHECK_DECLS([swapctl],,,[
#include <unistd.h>
#include <sys/types.h>
+ #include <sys/param.h>
#include <sys/stat.h>
#include <sys/swap.h>
])
AC_CHECK_TYPES([swaptbl_t, swapent_t],,,[
#include <sys/types.h>
+ #include <sys/param.h>
#include <sys/stat.h>
#include <sys/swap.h>
])
AC_CHECK_MEMBERS([struct swapent.se_nblks],,,[
#include <unistd.h>
#include <sys/types.h>
+ #include <sys/param.h>
#include <sys/stat.h>
#include <sys/swap.h>
])