aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorGravatar Thomas Guyot-Sionnest <dermoth@users.sourceforge.net> 2008-04-02 09:11:44 +0000
committerGravatar Thomas Guyot-Sionnest <dermoth@users.sourceforge.net> 2008-04-02 09:11:44 +0000
commit0d13deb0e44afb80ec0a35e827548d891d48f6b6 (patch)
tree7723807c1c17109104f6ebf3fea141e87a50ba46 /lib/Makefile.am
parent63897a417917907099b72f4e679890355a7a78a0 (diff)
downloadmonitoring-plugins-0d13deb0e44afb80ec0a35e827548d891d48f6b6.tar.gz
- Add --enable-extra-opts configure option for compiling extra-opts support
- Auto-update po/pot files git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1973 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 5d65bed6..73c12911 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -6,7 +6,11 @@ noinst_LIBRARIES = libnagiosplug.a
libnagiosplug_a_SOURCES = utils_base.c utils_disk.c utils_tcp.c utils_cmd.c
-EXTRA_DIST = utils_base.h utils_disk.h utils_tcp.h utils_cmd.h
+EXTRA_DIST = utils_base.h utils_disk.h utils_tcp.h utils_cmd.h parse_ini.h extra_opts.h
+
+if USE_PARSE_INI
+libnagiosplug_a_SOURCES += parse_ini.c extra_opts.c
+endif USE_PARSE_INI
INCLUDES = -I$(srcdir) -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins