aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2006-07-13 12:50:23 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2006-07-13 12:50:23 +0000
commit548083b2ea865474915fc8a9ddd361e997585a02 (patch)
treef3766c1f5d8f8ea1b2b721a5792e4fb4daf1cf68 /lib/Makefile.am
parent6b9cc76d0a27631fbab19a31ab8bd46e143b7580 (diff)
downloadmonitoring-plugins-548083b2ea865474915fc8a9ddd361e997585a02.tar.gz
Move new util_* functions to lib/
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1451 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 9a8991e1..0f40bf1f 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,5 +1,7 @@
## Process this file with automake to produce Makefile.in
+SUBDIRS = tests
+
noinst_LIBRARIES = libcoreutils.a libnagiosplug.a
# Will auto pick up fsusage.c mountlist.c
@@ -39,13 +41,16 @@ other_coreutils_files = \
libcoreutils_a_LIBADD = $(LIBOBJS)
libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD)
-libnagiosplug_a_SOURCES = snprintf.c
+libnagiosplug_a_SOURCES = snprintf.c utils_base.c utils_disk.c
-INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl
+INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
print_coreutil_files:
@echo $(libcoreutils_a_SOURCES) $(other_coreutils_files) $(EXTRA_DIST)
+test:
+ cd tests && make test
+
# Below are from coreutil's lib/Makefile.am
BUILT_SOURCES = $(STDBOOL_H)
EXTRA_DIST += stdbool_.h