aboutsummaryrefslogtreecommitdiff
path: root/lib/tests/Makefile.am
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2006-07-13 12:50:23 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2006-07-13 12:50:23 +0000
commit548083b2ea865474915fc8a9ddd361e997585a02 (patch)
treef3766c1f5d8f8ea1b2b721a5792e4fb4daf1cf68 /lib/tests/Makefile.am
parent6b9cc76d0a27631fbab19a31ab8bd46e143b7580 (diff)
downloadmonitoring-plugins-548083b2ea865474915fc8a9ddd361e997585a02.tar.gz
Move new util_* functions to lib/
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1451 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/tests/Makefile.am')
-rw-r--r--lib/tests/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/lib/tests/Makefile.am b/lib/tests/Makefile.am
new file mode 100644
index 00000000..63dee76e
--- /dev/null
+++ b/lib/tests/Makefile.am
@@ -0,0 +1,28 @@
+
+noinst_PROGRAMS = @EXTRA_TEST@
+
+# These two lines support "make check", but we use "make test"
+TESTS = @EXTRA_TEST@
+check_PROGRAMS = @EXTRA_TEST@
+
+INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
+
+EXTRA_PROGRAMS = test_utils test_disk
+
+EXTRA_DIST = test_utils.t test_disk.t
+
+LIBS = @LIBINTL@
+
+test_utils_SOURCES = test_utils.c
+test_utils_CFLAGS = -g -I..
+test_utils_LDFLAGS = -L/usr/local/lib -ltap
+test_utils_LDADD = ../utils_base.o
+
+test_disk_SOURCES = test_disk.c
+test_disk_CFLAGS = -g -I..
+test_disk_LDFLAGS = -L/usr/local/lib -ltap
+test_disk_LDADD = ../utils_disk.o
+
+test: ${noinst_PROGRAMS}
+ perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)
+