aboutsummaryrefslogtreecommitdiff
path: root/lib/tests/Makefile.am
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2007-09-21 23:01:28 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2007-09-21 23:01:28 +0000
commit8a39526e1b8754a8b8fbb50f7f6806af4def7baa (patch)
treec80f8ddafe75a920cdcec549e30e728bb57125f9 /lib/tests/Makefile.am
parent7a7052512953e6626edf8efc87664dba3ee01d74 (diff)
downloadmonitoring-plugins-8a39526e1b8754a8b8fbb50f7f6806af4def7baa.tar.gz
Stop double expansion of parameters for negate - works like
time command now git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1784 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/tests/Makefile.am')
-rw-r--r--lib/tests/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/lib/tests/Makefile.am b/lib/tests/Makefile.am
index 6594db2f..9ca22d16 100644
--- a/lib/tests/Makefile.am
+++ b/lib/tests/Makefile.am
@@ -7,9 +7,9 @@ check_PROGRAMS = @EXTRA_TEST@
INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
-EXTRA_PROGRAMS = test_utils test_disk test_tcp
+EXTRA_PROGRAMS = test_utils test_disk test_tcp test_cmd
-EXTRA_DIST = test_utils.t test_disk.t test_tcp.t
+EXTRA_DIST = test_utils.t test_disk.t test_tcp.t test_cmd.t
LIBS = @LIBINTL@
@@ -28,6 +28,11 @@ test_tcp_CFLAGS = -g -I..
test_tcp_LDFLAGS = -L/usr/local/lib -ltap
test_tcp_LDADD = ../utils_tcp.o
+test_cmd_SOURCES = test_cmd.c
+test_cmd_CFLAGS = -g -I..
+test_cmd_LDFLAGS = -L/usr/local/lib -ltap
+test_cmd_LDADD = ../utils_cmd.o ../utils_base.o
+
test: ${noinst_PROGRAMS}
perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)