aboutsummaryrefslogtreecommitdiff
path: root/lib/tests/Makefile.am
diff options
context:
space:
mode:
authorGravatar Matthias Eble <psychotrahe@users.sourceforge.net> 2007-06-03 15:14:15 +0000
committerGravatar Matthias Eble <psychotrahe@users.sourceforge.net> 2007-06-03 15:14:15 +0000
commitfdd2312171ef9ecc030abf522915f55a025f78bc (patch)
treeb425e88ec78b29384c1084772e21aa8522805222 /lib/tests/Makefile.am
parent0ad5dc61893b282ca3ea31c43bf0e372eb4de4cb (diff)
downloadmonitoring-plugins-fdd2312171ef9ecc030abf522915f55a025f78bc.tar.gz
Makefile.am changes for test_tcp.c
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1731 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/tests/Makefile.am')
-rw-r--r--lib/tests/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/lib/tests/Makefile.am b/lib/tests/Makefile.am
index cd9234e6..6594db2f 100644
--- a/lib/tests/Makefile.am
+++ b/lib/tests/Makefile.am
@@ -7,9 +7,9 @@ check_PROGRAMS = @EXTRA_TEST@
INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
-EXTRA_PROGRAMS = test_utils test_disk
+EXTRA_PROGRAMS = test_utils test_disk test_tcp
-EXTRA_DIST = test_utils.t test_disk.t
+EXTRA_DIST = test_utils.t test_disk.t test_tcp.t
LIBS = @LIBINTL@
@@ -23,6 +23,11 @@ test_disk_CFLAGS = -g -I..
test_disk_LDFLAGS = -L/usr/local/lib -ltap
test_disk_LDADD = ../utils_disk.o $(top_srcdir)/gl/libgnu.a
+test_tcp_SOURCES = test_tcp.c
+test_tcp_CFLAGS = -g -I..
+test_tcp_LDFLAGS = -L/usr/local/lib -ltap
+test_tcp_LDADD = ../utils_tcp.o
+
test: ${noinst_PROGRAMS}
perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)