aboutsummaryrefslogtreecommitdiff
path: root/plugins-scripts/Makefile.am
diff options
context:
space:
mode:
authorGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2014-02-28 13:28:33 +0100
committerGravatar Holger Weiss <holger@zedat.fu-berlin.de> 2014-02-28 13:28:33 +0100
commitc08d6a429ba0e0cd3642ba2c2fe85687472ee22f (patch)
tree396a37ae462543f0e28f36501c30796b3eb91249 /plugins-scripts/Makefile.am
parente260efb25690b13002a0bf432507f66bdad90f02 (diff)
downloadmonitoring-plugins-c08d6a429ba0e0cd3642ba2c2fe85687472ee22f.tar.gz
Replace "plugins-scripts/subst.in" foo
Remove the buggy and complex awk(1) magic in "plugins-scripts/subst.in" in favor of simple sed(1) substitutions. The plugins in the "plugins-scripts" directory now always use the PATH specified via "./configure --trusted-path", or the default PATH hard-coded in "configure.ac". Fixes #1242.
Diffstat (limited to 'plugins-scripts/Makefile.am')
-rw-r--r--plugins-scripts/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/plugins-scripts/Makefile.am b/plugins-scripts/Makefile.am
index 4ea262af..78a950c2 100644
--- a/plugins-scripts/Makefile.am
+++ b/plugins-scripts/Makefile.am
@@ -23,6 +23,11 @@ EXTRA_DIST=check_breeze.pl check_disk_smb.pl check_flexlm.pl check_ircd.pl \
check_ifstatus.pl check_ifoperstatus.pl check_wave.pl check_mailq.pl check_file_age.pl \
utils.sh.in utils.pm.in t
+EDIT = sed \
+ -e 's|[@]NP_VERSION[@]|$(NP_VERSION)|g' \
+ -e 's|[@]TRUSTED_PATH[@]|$(with_trusted_path)|g' \
+ -e 's|[@]PERL[@]|$(PERL)|g'
+
TESTS_ENVIRONMENT=perl -I $(top_builddir) -I $(top_srcdir)
TESTS = @SCRIPT_TEST@
@@ -38,11 +43,11 @@ test-debug:
CLEANFILES=$(libexec_SCRIPTS)
.pl :
- NP_VERSION=$(NP_VERSION) $(AWK) -f ./subst $< > $@
+ $(EDIT) $< > $@
chmod +x $@
.sh :
- NP_VERSION=$(NP_VERSION) $(AWK) -f ./subst $< > $@
+ $(EDIT) $< > $@
chmod +x $@
clean-local: