aboutsummaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorGravatar Ton Voon <tonvoon@users.sourceforge.net> 2006-01-30 16:10:50 +0000
committerGravatar Ton Voon <tonvoon@users.sourceforge.net> 2006-01-30 16:10:50 +0000
commit795100ae5124915bb647a304d5dfe2ada2f44ab0 (patch)
treeb3fd0dc1a88ebb533f074c476ee020e32877632e /plugins/Makefile.am
parentc8a9bf228fdd34b021796f577a404cb8b0cba1f9 (diff)
downloadmonitoring-plugins-795100ae5124915bb647a304d5dfe2ada2f44ab0.tar.gz
Added libtap tests for utils.c library functions. Removed redundant
test files git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1303 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 26f9c8a8..a67911ce 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,5 +1,7 @@
## Process this file with automake to produce Makefile.in
+SUBDIRS = tests
+
VPATH = $(top_srcdir) $(top_srcdir)/lib $(top_srcdir)/plugins $(top_srcdir)/plugins/t
INCLUDES = -I.. -I$(top_srcdir)/lib -I$(top_srcdir)/intl @LDAPINCLUDE@ @PGINCLUDE@ @SSLINCLUDE@
@@ -41,6 +43,7 @@ TESTS_ENVIRONMENT = perl -I $(top_builddir) -I $(top_srcdir)
TESTS = @PLUGIN_TEST@
test:
+ cd tests && make test
perl -I $(top_builddir) -I $(top_srcdir) ../test.pl
AM_INSTALL_PROGRAM_FLAGS = @INSTALL_OPTS@