aboutsummaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorGravatar Andreas Baumann <mail@andreasbaumann.cc> 2017-05-06 16:36:16 +0200
committerGravatar Sven Nierlein <sven@nierlein.de> 2018-10-22 16:30:31 +0200
commita739a5614834178ba88d04972b4f4ba9c560e1df (patch)
treee9ebee27575d064000e9e210dba2b36c914e8544 /plugins/Makefile.am
parent28a4c7076a3115d30aeb3b3b5e5bde715692e4a7 (diff)
downloadmonitoring-plugins-a739a5614834178ba88d04972b4f4ba9c560e1df.tar.gz
some rework:
- added old style 'redir' function and options along to a new libcurl internal 'follow' parameter 'curl' - moved picohttpparser to it's own subdirectory - added uriparser to be used instead of the home-grown parser in 'redir'
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index ff745c39..34a7da8b 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -40,17 +40,17 @@ EXTRA_PROGRAMS = check_mysql check_radius check_pgsql check_snmp check_hpjd \
check_nagios check_by_ssh check_dns check_nt check_ide_smart \
check_procs check_mysql_query check_apt check_dbi check_curl
+SUBDIRS = @PICOHTTPPARSER_DIR@ @URIPARSER_DIR@
+
EXTRA_DIST = t tests
PLUGINHDRS = common.h
-noinst_LIBRARIES = libnpcommon.a libpicohttpparser.a
+noinst_LIBRARIES = libnpcommon.a
libnpcommon_a_SOURCES = utils.c netutils.c sslutils.c runcmd.c \
popen.c utils.h netutils.h popen.h common.h runcmd.c runcmd.h
-libpicohttpparser_a_SOURCES = picohttpparser.c
-
BASEOBJS = libnpcommon.a ../lib/libmonitoringplug.a ../gl/libgnu.a
NETOBJS = $(BASEOBJS) $(EXTRA_NETOBLS)
NETLIBS = $(NETOBJS) $(SOCKETLIBS)
@@ -71,9 +71,9 @@ test-debug:
check_apt_LDADD = $(BASEOBJS)
check_cluster_LDADD = $(BASEOBJS)
-check_curl_CFLAGS = $(AM_CFLAGS) $(LIBCURLCFLAGS)
-check_curl_CPPFLAGS = $(AM_CPPFLAGS) $(LIBCURLINCLUDE)
-check_curl_LDADD = $(NETLIBS) $(LIBCURLLIBS) $(SSLOBJS) libpicohttpparser.a
+check_curl_CFLAGS = $(AM_CFLAGS) $(LIBCURLCFLAGS) -Ipicohttpparser -Iuriparser
+check_curl_CPPFLAGS = $(AM_CPPFLAGS) $(LIBCURLINCLUDE) -Ipicohttpparser -Iuriparser
+check_curl_LDADD = $(NETLIBS) $(LIBCURLLIBS) $(SSLOBJS) picohttpparser/libpicohttpparser.a uriparser/liburiparser.a
check_dbi_LDADD = $(NETLIBS) $(DBILIBS)
check_dig_LDADD = $(NETLIBS)
check_disk_LDADD = $(BASEOBJS)